bdswiss erfahrung

Welcome, Guest
Username: Password: Remember me

TOPIC: Eclipse warning with Android NDK version r9d causes Android.mk to fail

Eclipse warning with Android NDK version r9d causes Android.mk to fail 07 Jul 2014 19:03 #10

  • cwheatley
  • cwheatley's Avatar
  • Offline
  • Administrator
  • Posts: 9
  • Thank you received: 1
  • Karma: 0
Eclipse has an issue that causes Onyx not to build correctly. The regular expressions are incorrect. The following excerpt from the linked post details how to modify Eclipse to correct this issue.

code.google.com/p/android/issues/detail?id=39752

Open Eclipse and perform the following instructions:

Window -> Preferences -> C/C++ -> Build -> Settings
Select CDT GNU C/C++ Error Parser
In the Error Parser options at the bottom, add a new entry with the following contents:
Severity: Warning
Pattern: (.*?):(\d+): Android NDK: WARNING:(.*)
File: $1
Line: $2
Description: $3

That should convert this to a warning, and you can choose to ignore this as well - depending on the severity it will show up in the Problems view.

Additionally, disable the following existing entry (if it exists):
Severity: Error
Pattern: (.*?):(\d+):(\d+:)? (.*)
File: $1
Line: $2
Description: $4
The administrator has disabled public write access.
Time to create page: 0.106 seconds